aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2013-02-11 21:41:34 +0100
committerAndreas Schneider <asn@cryptomilk.org>2013-07-13 14:07:46 +0200
commit2b54db76034dfd4b546e1d7cf800183d51427ca8 (patch)
tree5ef204474eb56e3aa2f7409276a870cd1a66753e /examples/CMakeLists.txt
parentff30a8feb0f6b44fe8708b9e6650992c360dd06f (diff)
downloadlibssh-2b54db76034dfd4b546e1d7cf800183d51427ca8.tar.gz
libssh-2b54db76034dfd4b546e1d7cf800183d51427ca8.tar.xz
libssh-2b54db76034dfd4b546e1d7cf800183d51427ca8.zip
Try to find ARGP on solaris, BSD
Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 5513b758..c2f58cb9 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -11,6 +11,10 @@ include_directories(
${CMAKE_BINARY_DIR}
)
+if (BSD OR SOLARIS)
+ find_package(Argp)
+endif (BSD OR SOLARIS)
+
if (LINUX)
add_executable(libssh_scp libssh_scp.c ${examples_SRCS})
target_link_libraries(libssh_scp ${LIBSSH_SHARED_LIBRARY})