aboutsummaryrefslogtreecommitdiff
path: root/examples/CMakeLists.txt
diff options
context:
space:
mode:
authormilo <milo@r0ot.me>2011-02-20 13:07:34 +0100
committermilo <milo@r0ot.me>2011-02-20 14:37:43 +0100
commit000d659ea2eb709bf99e27c4c76233032869294f (patch)
tree8eaf5333f858a388119ebd9a392eac23d5113180 /examples/CMakeLists.txt
parentddb1c1838f35818db92809d92c999a1352be5521 (diff)
downloadlibssh-000d659ea2eb709bf99e27c4c76233032869294f.tar.gz
libssh-000d659ea2eb709bf99e27c4c76233032869294f.tar.xz
libssh-000d659ea2eb709bf99e27c4c76233032869294f.zip
examples: Added a event context based sshd example.
Diffstat (limited to 'examples/CMakeLists.txt')
-rw-r--r--examples/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/examples/CMakeLists.txt b/examples/CMakeLists.txt
index 1ccd8f27..5513b758 100644
--- a/examples/CMakeLists.txt
+++ b/examples/CMakeLists.txt
@@ -35,6 +35,12 @@ if (LINUX)
add_executable(samplesshd-kbdint samplesshd-kbdint.c)
target_link_libraries(samplesshd-kbdint ${LIBSSH_SHARED_LIBRARY})
+
+ if (HAVE_LIBUTIL)
+ add_executable(samplesshd-tty samplesshd-tty.c)
+ target_link_libraries(samplesshd-tty ${LIBSSH_SHARED_LIBRARY} util)
+ endif (HAVE_LIBUTIL)
+
endif (WITH_SERVER)
endif (LINUX)