aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2005-10-26 12:56:52 +0000
committerAris Adamantiadis <aris@0xbadc0de.be>2005-10-26 12:56:52 +0000
commit5e02c25291d594e01a910fce097a3fc5084fd68f (patch)
treea10e8ba2001f7dd296245e4317ee51a035e39c53 /configure.in
parentb753dae37ee09f9fd0576d5fb920b8f9a4cf4e48 (diff)
downloadlibssh-5e02c25291d594e01a910fce097a3fc5084fd68f.tar.gz
libssh-5e02c25291d594e01a910fce097a3fc5084fd68f.tar.xz
libssh-5e02c25291d594e01a910fce097a3fc5084fd68f.zip
good, now it compiles (removed the -Wl-O1 thing as Giga said.)
removed the configure file from the svn (just do autoconf next time). git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@43 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 51b9a573..5d6bca81 100644
--- a/configure.in
+++ b/configure.in
@@ -32,17 +32,17 @@ AC_SUBST(LIBSSH_LDFLAGS)
AC_MSG_CHECKING([version script options])
case "$host" in
*-*-linux*)
- LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers -Wl,-01"
+ LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers"
;;
*-*-gnu*)
- LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers-Wl,-01"
+ LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers"
;;
esac
AC_ARG_WITH([versioned-symbol],
AC_HELP_STRING([--with-versioned-symbol],[Use versioned symbols]),
[echo $withval > plop
if test $withval = "yes"; then
- LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers-Wl,-01"
+ LIBSSH_VERS="$LIBSSH_LDFLAGS -Wl,--version-script,libssh.vers"
else
LIBSSH_VERS=""
fi], [ : ])