aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLaurent Bigonville <l.bigonville@edpnet.be>2007-07-31 17:54:25 +0000
committerLaurent Bigonville <l.bigonville@edpnet.be>2007-07-31 17:54:25 +0000
commit93af231d145db8f03938d49f62a07c3bf0134738 (patch)
treefb4d08477b73e908765dd2824b2331ffe57f4ad1 /configure.ac
parent961ef240ec6f41bd0466c7de88bd52f4e6d765f8 (diff)
downloadlibssh-93af231d145db8f03938d49f62a07c3bf0134738.tar.gz
libssh-93af231d145db8f03938d49f62a07c3bf0134738.tar.xz
libssh-93af231d145db8f03938d49f62a07c3bf0134738.zip
Better automake files
git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@128 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4c8bb299..0a65cb21 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,10 +3,12 @@
AC_PREREQ(2.57)
AC_INIT([libssh], 0.2, [aris@0xbadc0de.be])
-AM_INIT_AUTOMAKE
+AM_INIT_AUTOMAKE(1.9)
AC_CONFIG_SRCDIR([sample.c])
AC_CONFIG_HEADER([config.h])
+AM_MAINTAINER_MODE
+
# LT Version numbers, remember to change them just *before* a release.
# (Interfaces removed: CURRENT++, AGE=0, REVISION=0)
# (Interfaces added: CURRENT++, AGE++, REVISION=0)
@@ -65,6 +67,9 @@ AC_PROG_MAKE_SET
AC_PROG_LIBTOOL
AC_C_BIGENDIAN
+AC_CHECK_PROG([DOXYGEN], [doxygen], [yes], [no])
+AM_CONDITIONAL([HAS_DOXYGEN], [test x"$DOXYGEN" = xyes])
+
# Checks for libraries.
with_gcrypt=${with_gcrypt:-"no"}
AC_ARG_WITH([libgcrypt],