aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2008-11-05 16:42:43 +0000
committerAris Adamantiadis <aris@0xbadc0de.be>2008-11-05 16:42:43 +0000
commit11e3d3ebab09112cd163268178bafeb5d6b48f87 (patch)
tree3efd4665f763309873e60e3ed57882ddfe00b4b9 /Makefile.am
parent64e73b8d8ab216c5dd8812c8cdad39b7f1bfc4d2 (diff)
downloadlibssh-11e3d3ebab09112cd163268178bafeb5d6b48f87.tar.gz
libssh-11e3d3ebab09112cd163268178bafeb5d6b48f87.tar.xz
libssh-11e3d3ebab09112cd163268178bafeb5d6b48f87.zip
More doxygen documentation (internal set)
split of the sftp_async_read function git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@188 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 56004f73..b3c3502d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,17 +24,21 @@ install-doc: doxygen
$(INSTALL) -d $(DESTDIR)$(mandir)/man3
$(INSTALL) --mode=644 doxygen/man/man3/* $(DESTDIR)$(mandir)/man3
-doxygen:
+doxygen: clean-local
@echo "Running doxygen..."
doxygen $(srcdir)/Doxyfile
+doxygen-dev: clean-local
+ @echo "Running internal doxygen"
+ doxygen $(srcdir)/Doxyfile.internal
else
doxygen:
+doxygen-dev:
install-doc: doxygen
endif
clean-local:
-rm -rf doxygen
-EXTRA_DIST = Doxyfile
+EXTRA_DIST = Doxyfile Doxyfile.internal
CLEANFILES = samplesftp