aboutsummaryrefslogtreecommitdiff
path: root/INSTALL
diff options
context:
space:
mode:
authorDirkjan Bussink <d.bussink@gmail.com>2020-12-16 12:23:23 +0100
committerAndreas Schneider <asn@cryptomilk.org>2020-12-22 09:15:38 +0100
commite20fe54f3f80fa07819e2775b5be4a2e3fafb46f (patch)
tree22688b083bba586ba6641d64178164f1f1e4d747 /INSTALL
parent919387ae644b607b021c110dbe3b5bee9df08d91 (diff)
downloadlibssh-e20fe54f3f80fa07819e2775b5be4a2e3fafb46f.tar.gz
libssh-e20fe54f3f80fa07819e2775b5be4a2e3fafb46f.tar.xz
libssh-e20fe54f3f80fa07819e2775b5be4a2e3fafb46f.zip
Bump minimum version requirement for OpenSSL
This updates the minimum version requirement for OpenSSL in the documentation to 1.0.1 and also updates the practical minimum CMake version. Why pick 1.0.1 as the minimum? Main reason is whatever is still out there with long term support contracts etc. One of the oldest I could find is Ubuntu 14.04 which still has paid extended support and is on 1.0.1. Another reason that 1.0.1 is probably a good minimum is a bit more involved. 1.0.1 is the first version to add TLS 1.2. Large parts of the internet have TLS 1.2 as a minimum requirement. This means that systems with OpenSSL older than 1.0.1 already can't access large parts of the internet anyway, so not supporting the latest libssh there either is ok I think. Bumping minimum support also means things like the HMAC API can be moved to the more recent EVP style APIs and things can be more easily made compatible with the deprecated APIs in OpenSSL 3.0. Signed-off-by: Dirkjan Bussink <d.bussink@gmail.com> Reviewed-by: Jakub Jelen <jjelen@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'INSTALL')
-rw-r--r--INSTALL4
1 files changed, 2 insertions, 2 deletions
diff --git a/INSTALL b/INSTALL
index 0f0cebfb..c2eae34b 100644
--- a/INSTALL
+++ b/INSTALL
@@ -7,8 +7,8 @@
In order to build libssh, you need to install several components:
- A C compiler
-- [CMake](https://www.cmake.org) >= 2.6.0.
-- [openssl](https://www.openssl.org) >= 0.9.8
+- [CMake](https://www.cmake.org) >= 3.3.0
+- [openssl](https://www.openssl.org) >= 1.0.1
or
- [gcrypt](https://www.gnu.org/directory/Security/libgcrypt.html) >= 1.4
- [libz](https://www.zlib.net) >= 1.2