aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-06-11 10:43:02 +0200
committerAndreas Schneider <asn@cynapses.org>2010-06-11 10:43:02 +0200
commitf57d2c327726b93741e986f7dc60f81007330dc9 (patch)
tree50bbc589b208289061b4f74cfd2e9cbcaec62534 /CMakeLists.txt
parent11a1ae59f4954b4109cbf0d54b058157d8402886 (diff)
downloadlibssh-f57d2c327726b93741e986f7dc60f81007330dc9.tar.gz
libssh-f57d2c327726b93741e986f7dc60f81007330dc9.tar.xz
libssh-f57d2c327726b93741e986f7dc60f81007330dc9.zip
build: Fixed building without zlib.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8fa78c52..dd6b69ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,9 @@ include(MacroAddPlugin)
include(MacroCopyFile)
# search for libraries
-find_package(ZLIB REQUIRED)
+if (WITH_LIBZ)
+ find_package(ZLIB REQUIRED)
+endif (WITH_LIBZ)
if (WITH_GCRYPT)
find_package(GCrypt REQUIRED)