aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2010-03-25 13:24:59 +0100
committerAndreas Schneider <mail@cynapses.org>2010-03-25 13:26:37 +0100
commite4bbba2b15c51fc3e9a7ee1165d20fb9905dee1d (patch)
tree8f484e5977f3dd95bb4fed78b5598eee11a45692 /CMakeLists.txt
parent3a5af7fb61e49123d824fcf42caaa471c8b09797 (diff)
downloadlibssh-e4bbba2b15c51fc3e9a7ee1165d20fb9905dee1d.tar.gz
libssh-e4bbba2b15c51fc3e9a7ee1165d20fb9905dee1d.tar.xz
libssh-e4bbba2b15c51fc3e9a7ee1165d20fb9905dee1d.zip
Added comments to the so version to increment it correctly in future.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 238c6b8d..444addd1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,6 +12,13 @@ set(APPLICATION_VERSION_PATCH "0")
set(APPLICATION_VERSION "${APPLICATION_VERSION_MAJOR}.${APPLICATION_VERSION_MINOR}.${APPLICATION_VERSION_PATCH}")
+# Set the lib CURRENT.AGE.REVISION version info
+# If the source code was changed, but there were no interface changes:
+# Increment REVISION.
+# If there was a compatible interface change:
+# Increment CURRENT and AGE. Set REVISION to 0
+# If there was an incompatible interface change:
+# Increment CURRENT. Set AGE and REVISION to 0
set(LIBRARY_VERSION "4.1.0")
set(LIBRARY_SOVERSION "4")