aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2019-03-11 15:56:06 +0100
committerAndreas Schneider <asn@cryptomilk.org>2019-04-01 08:38:17 +0200
commitd6d9b56bb9c96eb15329b5530b41e742cef04dde (patch)
tree2c09be1498c474218af6624f2278ab992a6b3bbf /CMakeLists.txt
parent68385a2e983a30c3013663e4cc934a67a9878ea5 (diff)
downloadlibssh-d6d9b56bb9c96eb15329b5530b41e742cef04dde.tar.gz
libssh-d6d9b56bb9c96eb15329b5530b41e742cef04dde.tar.xz
libssh-d6d9b56bb9c96eb15329b5530b41e742cef04dde.zip
cmake,options: Allow to set global bind config file
This allows the global bind configuration file path to be set in configuration time by defining the GLOBAL_BIND_CONFIG when calling cmake. If no value is defined, the default path is set as "/etc/ssh/libssh_server_config". usage example: $ cmake -DGLOBAL_BIND_CONFIG=/etc/my/custom/path .. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bbd7d771..6bffbc6d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,5 +243,8 @@ message(STATUS "Benchmarks: ${WITH_BENCHMARKS}")
message(STATUS "Symbol versioning: ${WITH_SYMBOL_VERSIONING}")
message(STATUS "Allow ABI break: ${WITH_ABI_BREAK}")
message(STATUS "Release is final: ${WITH_FINAL}")
+if (WITH_SERVER)
+message(STATUS "Global bind config: ${GLOBAL_BIND_CONFIG}")
+endif()
message(STATUS "********************************************")