aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-09-16 08:21:12 +0200
committerAndreas Schneider <asn@cryptomilk.org>2013-09-16 10:38:14 +0200
commitb9ada252964acff8f5e17ddab9c654e0743b960a (patch)
tree0fe485961656b14995b320a44b8096b7f1432bf1 /CMakeLists.txt
parent33cb1bc08bb150e35055a17aae93efc7e5da5940 (diff)
downloadlibssh-b9ada252964acff8f5e17ddab9c654e0743b960a.tar.gz
libssh-b9ada252964acff8f5e17ddab9c654e0743b960a.tar.xz
libssh-b9ada252964acff8f5e17ddab9c654e0743b960a.zip
cmake: Allow to build without examples.
BUG: https://red.libssh.org/issues/114
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e783c2b4..2c5c7232 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,7 +109,9 @@ install(
# in tree build settings
configure_file(libssh-build-tree-settings.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/libssh-build-tree-settings.cmake @ONLY)
-add_subdirectory(examples)
+if (WITH_EXAMPLES)
+ add_subdirectory(examples)
+endif (WITH_EXAMPLES)
if (WITH_TESTING)
find_package(CMocka REQUIRED)