aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-09-01 15:15:17 +0200
committerAndreas Schneider <asn@cynapses.org>2010-09-01 15:15:17 +0200
commita93f2d8bfe98e2927fc7024973c52062ccd28b30 (patch)
tree7fea3f5be30c1914c2fe751291c8baa0b98d12c5 /CMakeLists.txt
parent8c55294ea9134c32f80d1a399a6a49ecdc9264b2 (diff)
downloadlibssh-a93f2d8bfe98e2927fc7024973c52062ccd28b30.tar.gz
libssh-a93f2d8bfe98e2927fc7024973c52062ccd28b30.tar.xz
libssh-a93f2d8bfe98e2927fc7024973c52062ccd28b30.zip
build: Fixed pthread detection.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e7c5b6ce..0cd833b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,8 +62,10 @@ else (WITH_GCRYPT)
endif (NOT OPENSSL_FOUND)
endif(WITH_GCRYPT)
-#find out if we have threading available
-include(FindThreads)
+# Find out if we have threading available
+set(CMAKE_THREAD_PREFER_PTHREADS ON)
+find_package(Threads)
+
# config.h checks
include(ConfigureChecks.cmake)
configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)