aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2018-09-05 15:14:14 +0200
committerAndreas Schneider <asn@cryptomilk.org>2018-09-05 15:28:29 +0200
commit91800eb2436269993493b606b905cf0572e945e2 (patch)
tree68c07713e840767d8667b7a17bcc4686c716b675 /CMakeLists.txt
parent2923ad59f9d2598418e7ba6369cb9fafc21cea09 (diff)
downloadlibssh-91800eb2436269993493b606b905cf0572e945e2.tar.gz
libssh-91800eb2436269993493b606b905cf0572e945e2.tar.xz
libssh-91800eb2436269993493b606b905cf0572e945e2.zip
cmake: Move CompilerFlags to own file
They need to be included before the project() call. Signed-off-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bd3f6932..be41e433 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,6 +8,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules")
# Add defaults for cmake
# Those need to be set before the project() call.
include(DefineCMakeDefaults)
+include(DefineCompilerFlags)
project(libssh VERSION 0.8.90 LANGUAGES C)