aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Toshiyuki Sasaki <ansasaki@redhat.com>2019-05-06 15:19:40 +0200
committerAndreas Schneider <asn@cryptomilk.org>2019-05-14 17:20:39 +0200
commit7cc159d72079770937b9aebadf40e9f2c4fafbc6 (patch)
treef6a912082c1b9f9e7a023bdaaba2566974bfa830 /CMakeLists.txt
parent248e5acd5c9f9bb08b7d04dce13564bf4c817cca (diff)
downloadlibssh-7cc159d72079770937b9aebadf40e9f2c4fafbc6.tar.gz
libssh-7cc159d72079770937b9aebadf40e9f2c4fafbc6.tar.xz
libssh-7cc159d72079770937b9aebadf40e9f2c4fafbc6.zip
cmake,options: Allow to set global client config file
This allows the global client (ssh_session) configuration file path to be set in configuration time by defining GLOBAL_CLIENT_CONFIG when calling cmake. If it is not defined, the default path is set as "/etc/ssh/ssh_config". usage example: $ cmake -DGLOBAL_CLIENT_CONFIG=/etc/my/custom/path .. Signed-off-by: Anderson Toshiyuki Sasaki <ansasaki@redhat.com> Reviewed-by: Andreas Schneider <asn@cryptomilk.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6bffbc6d..0681e6e0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,6 +243,7 @@ message(STATUS "Benchmarks: ${WITH_BENCHMARKS}")
message(STATUS "Symbol versioning: ${WITH_SYMBOL_VERSIONING}")
message(STATUS "Allow ABI break: ${WITH_ABI_BREAK}")
message(STATUS "Release is final: ${WITH_FINAL}")
+message(STATUS "Global client config: ${GLOBAL_CLIENT_CONFIG}")
if (WITH_SERVER)
message(STATUS "Global bind config: ${GLOBAL_BIND_CONFIG}")
endif()