aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2016-03-14 22:27:06 +0100
committerAris Adamantiadis <aris@0xbadc0de.be>2016-03-14 22:27:06 +0100
commit50276273448d042084ee44bc0cfae152c8abc110 (patch)
treeb166a4571a0d916e0931bc9322a994ffbd988b41 /CMakeLists.txt
parent4d43fbfb50710055352c4fda812b6dc98143d336 (diff)
downloadlibssh-50276273448d042084ee44bc0cfae152c8abc110.tar.gz
libssh-50276273448d042084ee44bc0cfae152c8abc110.tar.xz
libssh-50276273448d042084ee44bc0cfae152c8abc110.zip
cmake: detect argp.h on osx
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 445710a0..30b1025c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -74,6 +74,10 @@ if (WITH_NACL)
endif (NOT NACL_FOUND)
endif (WITH_NACL)
+if (BSD OR SOLARIS OR OSX)
+ find_package(Argp)
+endif (BSD OR SOLARIS OR OSX)
+
# config.h checks
include(ConfigureChecks.cmake)
configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)