aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2010-03-17 10:09:38 +0100
committerAndreas Schneider <mail@cynapses.org>2010-03-17 10:12:03 +0100
commit3a5af7fb61e49123d824fcf42caaa471c8b09797 (patch)
treecdb5555272bf78c5a97fbc9e758b4e6f266bc96d /CMakeLists.txt
parent34f2d50e29669b1db745351f86a497148e69c6f3 (diff)
downloadlibssh-3a5af7fb61e49123d824fcf42caaa471c8b09797.tar.gz
libssh-3a5af7fb61e49123d824fcf42caaa471c8b09797.tar.xz
libssh-3a5af7fb61e49123d824fcf42caaa471c8b09797.zip
Build examples only on the Linux plattform.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 498f36ef..238c6b8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -73,9 +73,9 @@ install(
pkgconfig
)
-if (UNIX AND NOT WIN32)
+if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
add_subdirectory(examples)
-endif (UNIX AND NOT WIN32)
+endif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
if (WITH_TESTING)
find_package(Check REQUIRED)