aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2010-03-15 16:09:16 +0100
committerAndreas Schneider <mail@cynapses.org>2010-03-15 16:09:16 +0100
commit34f2d50e29669b1db745351f86a497148e69c6f3 (patch)
treec5c72c622d9c035c0b5ff7476762baa4ca99d17f /CMakeLists.txt
parent40d0ca7963422e300145f1a70cc4dbc7ffec065c (diff)
downloadlibssh-34f2d50e29669b1db745351f86a497148e69c6f3.tar.gz
libssh-34f2d50e29669b1db745351f86a497148e69c6f3.tar.xz
libssh-34f2d50e29669b1db745351f86a497148e69c6f3.zip
Require check if testing is enabled.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 025273b5..498f36ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,7 +37,6 @@ include(MacroCopyFile)
# search for libraries
find_package(ZLIB REQUIRED)
-find_package(Check)
if (WITH_GCRYPT)
find_package(GCrypt REQUIRED)
@@ -78,10 +77,11 @@ if (UNIX AND NOT WIN32)
add_subdirectory(examples)
endif (UNIX AND NOT WIN32)
-if (CHECK_FOUND AND WITH_TESTING)
+if (WITH_TESTING)
+ find_package(Check REQUIRED)
include(AddCheckTest)
add_subdirectory(tests)
-endif (CHECK_FOUND AND WITH_TESTING)
+endif (WITH_TESTING)
message(STATUS "********************************************")
message(STATUS "********** ${PROJECT_NAME} build options : **********")