aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cynapses.org>2010-12-28 13:41:33 +0100
committerAndreas Schneider <asn@cynapses.org>2010-12-28 22:14:47 +0100
commit17f592d4dd25eae98b1a8378625adc454976fcb6 (patch)
tree753072ed82b75b78801dd0e5786a8bbe9b272e64 /CMakeLists.txt
parent7dc183126ab53d0788d48066054a8282d63c0d17 (diff)
downloadlibssh-17f592d4dd25eae98b1a8378625adc454976fcb6.tar.gz
libssh-17f592d4dd25eae98b1a8378625adc454976fcb6.tar.xz
libssh-17f592d4dd25eae98b1a8378625adc454976fcb6.zip
tests: Start to migrate tests to cmockery.
https://code.google.com/p/cmockery/wiki/Cmockery_Unit_Testing_Framework
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 86e80ee0..a96eec81 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -92,8 +92,8 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Linux")
endif (CMAKE_SYSTEM_NAME STREQUAL "Linux")
if (WITH_TESTING)
- find_package(Check REQUIRED)
- include(AddCheckTest)
+ find_package(CMockery REQUIRED)
+ include(AddCMockeryTest)
add_subdirectory(tests)
endif (WITH_TESTING)