aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorVic Lee <llyzs@163.com>2009-12-30 13:34:17 +0800
committerAndreas Schneider <mail@cynapses.org>2009-12-30 19:05:48 +0100
commit13d534e89a44239f743eeaa63dbec47a13798bb7 (patch)
tree210112aac9edc525b2fdda512ccf9464b17419f7 /CMakeLists.txt
parent1944dc8b5ff51daae505b5ee32c3b82c2ac4bf86 (diff)
downloadlibssh-13d534e89a44239f743eeaa63dbec47a13798bb7.tar.gz
libssh-13d534e89a44239f743eeaa63dbec47a13798bb7.tar.xz
libssh-13d534e89a44239f743eeaa63dbec47a13798bb7.zip
Add pkg-config file libssh.pc
Signed-off-by: Vic Lee <llyzs@163.com> Signed-off-by: Andreas Schneider <mail@cynapses.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 944beb5e..57382311 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,6 +66,17 @@ add_subdirectory(tests)
# build samples
include_directories(${CMAKE_SOURCE_DIR}/include)
+# pkg-config file
+configure_file(libssh.pc.cmake ${CMAKE_CURRENT_BINARY_DIR}/libssh.pc)
+install(
+ FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/libssh.pc
+ DESTINATION
+ ${LIB_INSTALL_DIR}/pkgconfig
+ COMPONENT
+ pkgconfig
+)
+
if (UNIX AND NOT WIN32)
add_subdirectory(examples)