aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <mail@cynapses.org>2009-04-27 10:58:29 +0000
committerAndreas Schneider <mail@cynapses.org>2009-04-27 10:58:29 +0000
commitc1c4f299ff8881fe0c8d51790d49bfb5fcd632df (patch)
treeb6d448bb156f7d4025778e5f76740ab7edb30dac /CMakeLists.txt
parent99946c7bcc3be1a48e2546254e3c7e9ca8375412 (diff)
downloadlibssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.tar.gz
libssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.tar.xz
libssh-c1c4f299ff8881fe0c8d51790d49bfb5fcd632df.zip
Add option to build with or without sftp support.
git-svn-id: svn+ssh://svn.berlios.de/svnroot/repos/libssh/trunk@618 7dcaeef0-15fb-0310-b436-a5af3365683c
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36587c5a..f31ddf08 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -60,9 +60,11 @@ add_subdirectory(libssh)
include_directories(${CMAKE_SOURCE_DIR}/include)
if (UNIX AND NOT WIN32)
- add_executable(samplessh sample.c)
- add_executable(samplesshd samplesshd.c)
+ if (WITH_SFTP AND WITH_SERVER)
+ add_executable(samplessh sample.c)
+ add_executable(samplesshd samplesshd.c)
- target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
- target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY})
+ target_link_libraries(samplessh ${LIBSSH_SHARED_LIBRARY})
+ target_link_libraries(samplesshd ${LIBSSH_SHARED_LIBRARY})
+ endif (WITH_SFTP AND WITH_SERVER)
endif (UNIX AND NOT WIN32)