aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAndreas Schneider <asn@cryptomilk.org>2013-09-16 08:21:12 +0200
committerAndreas Schneider <asn@cryptomilk.org>2013-10-01 14:47:57 +0200
commit44f851d2876fad4907cde1eec8ba6f4801de846e (patch)
treecb5d4d4418ecc91ba3e1f5f5cd84a811b29a6715 /CMakeLists.txt
parent3d158fffa0ba78ffd517da941fd0ff1ba908d796 (diff)
downloadlibssh-44f851d2876fad4907cde1eec8ba6f4801de846e.tar.gz
libssh-44f851d2876fad4907cde1eec8ba6f4801de846e.tar.xz
libssh-44f851d2876fad4907cde1eec8ba6f4801de846e.zip
cmake: Allow to build without examples.
BUG: https://red.libssh.org/issues/114
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 14175969..d0520e7b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -109,7 +109,9 @@ install(
# in tree build settings
configure_file(libssh-build-tree-settings.cmake.in ${CMAKE_CURRENT_BINARY_DIR}/libssh-build-tree-settings.cmake @ONLY)
-add_subdirectory(examples)
+if (WITH_EXAMPLES)
+ add_subdirectory(examples)
+endif (WITH_EXAMPLES)
if (WITH_TESTING)
find_package(CMocka REQUIRED)